Mobility Route - Email System Issues (Fixed0 – Incident details
Twilio SMS experiencing degraded performance
Email System Issues (Fixed0
Resolved
Operational
Started 23 days agoJune 26, 2026Lasted 11 days11:00 PMJuly 07, 202610:26 PMUTC
Affected
Communication Services
Operational from 11:00 PM to 10:26 PM
Email Service
Operational from 11:00 PM to 10:26 PM
Updates
Resolved
UTC
Resolved
UTC
This incident has been resolved.
Monitoring
UTC
Monitoring
UTC
We had a few recent reports about an outage affecting some email sending from the Mobility Route system. Our third-party provider has confirmed the issue should be resolved.